보안악용 확인 · 악용 확률 · 한국어 권고
● 실제 악용이 확인됨 · 2025-04-01 등재

CVE-2025-24813
Apache Tomcat

Apache Tomcat contains a path equivalence vulnerability that allows a remote attacker to execute code, disclose information, or inject malicious content via a partial PUT request. This vulnerability c…

심각9.8악용 확률 99.94%CWE-44공개 2025-03-10
9.8APCWE-44

📌 이 취약점에 대해 확인된 사실

전부 발행처가 발표한 값입니다. 우리가 계산하거나 판단한 숫자는 하나도 없습니다.

악용 여부

악용 확인

KEV 등재일2025-04-01
미국 기관 조치 기한2025-04-22
랜섬웨어 사용CISA 미확인

심각도 (발행처 발표값)

심각9.8

CVSS 버전3.1
평가 기관NVD (미국 NIST)

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

악용 확률 (EPSS)

99.9%

30일 내 악용 확률99.94%
전체 CVE 중 백분위100.0%
기준일2026-11-03

🇰🇷 한국어 공식 권고

KISA 보호나라 권고문 본문에서 이 CVE 번호가 발견된 문서입니다.

전체 권고 ›
이 CVE 를 다룬 KISA 보호나라 권고를 아직 찾지 못했습니다. 권고가 없다는 확증은 아닙니다 — 우리는 RSS 로 공개된 최근 공지만 수집합니다.

📄 원문 그대로

아래 문장은 전부 발행처가 쓴 것입니다. 번역하지 않습니다 — 보안 문서의 오역은 조치를 바꿉니다.

취약점 설명 (NVD)

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

약점 유형(CWE):CWE-44CWE-502CWE-502CWE-706

참조 문서 10건 · NVD 분석 상태 Analyzed · 수집 2026-09-04

CISA 원문

Apache Tomcat contains a path equivalence vulnerability that allows a remote attacker to execute code, disclose information, or inject malicious content via a partial PUT request. This vulnerability can be chained with CVE‑2026‑34486.— CISA KEV · shortDescription 원문
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.— CISA KEV · requiredAction 원문

위 문장은 CISA 가 미국 연방기관에 지시한 내용을 원문 그대로 옮긴 것입니다. 국내 조직에 그대로 적용되는 의무가 아니며, 우리가 덧붙인 판단도 아닙니다.

악용 확률 변화

우리가 매일 저장한 EPSS 스냅샷입니다. 원본은 전날 값만 주므로, 이 표는 수집을 시작한 이후만 보여줍니다.

기준일확률백분위
2026-11-0399.94%100.0%
2026-11-0299.94%100.0%
2026-11-0199.94%100.0%
2026-10-3199.94%100.0%
2026-10-3099.94%100.0%
2026-10-2999.94%100.0%
2026-10-2899.94%100.0%
2026-10-2799.94%100.0%
2026-10-2699.94%100.0%
2026-10-2599.94%100.0%
2026-10-2499.93%100.0%
2026-10-2399.93%100.0%
2026-10-2299.93%100.0%
2026-10-2199.93%100.0%
이 페이지는 조치 지시가 아닙니다. 영향 범위와 패치 버전은 제품·구성에 따라 다르므로, 반드시 공급사 공식 권고와 NVD 원문의 참조 링크를 확인하세요.